[{"data":1,"prerenderedAt":61},["ShallowReactive",2],{"post:grant-permissions-for-mysql-dump":3},{"id":4,"title":5,"body":6,"date":48,"description":49,"draft":50,"extension":51,"meta":52,"navigation":53,"path":54,"seo":55,"stem":56,"tags":57,"__hash__":60},"posts\u002Fposts\u002Fgrant-permissions-for-mysql-dump.md","TIL: GRANT Permissions for MySQLDump Backups",{"type":7,"value":8,"toc":45},"minimark",[9,26,36,39],[10,11,12,13,17,18,21,22,25],"p",{},"Turns out that running ",[14,15,16],"code",{},"mysqldump"," against a database takes more than just ",[14,19,20],{},"SELECT"," permissions. Use this ",[14,23,24],{},"GRANT"," command to grant the necessary privileges for dumping a database.",[27,28,33],"pre",{"className":29,"code":31,"language":32},[30],"language-text","GRANT SELECT, LOCK TABLES, SHOW VIEW, TRIGGER ON myDatabase.* TO myUser@localhost IDENTIFIED BY 'password_string;\nFLUSH PRIVILEGES\n","text",[14,34,31],{"__ignoreMap":35},"",[10,37,38],{},"If you forget one of these, or need an extra GRANT, you may get an error like:",[27,40,43],{"className":41,"code":42,"language":32},[30],"mysqldump: Got error: 1044: Access denied for user 'myUser'@'localhost' to database 'myDatabase' when using LOCK TABLES\n",[14,44,42],{"__ignoreMap":35},{"title":35,"searchDepth":46,"depth":46,"links":47},2,[],"2018-10-18T03:13:38-04:00","Turns out that running mysqldump against a database takes more than just SELECT permissions. Use this GRANT command to grant the necessary privileges for dumping a database.",false,"md",{},true,"\u002Fposts\u002Fgrant-permissions-for-mysql-dump",{"title":5,"description":49},"posts\u002Fgrant-permissions-for-mysql-dump",[58,59],"mysql","til","YIU2cZFKXMUIU6dVMOTpvKn_Le-BCW9ioTTyJrOsGtI",1790471528077]